Jump to content

dealio

Members
  • Posts

    93
  • Joined

  • Last visited

  • Days Won

    6

Everything posted by dealio

  1. Ed, You are not alone. I have exactly the same problem on my laptop. I have the HomeManage database on a local NAS on my home network and I can access it from either my desktop or my laptop, both of which run Windows 10 x64 (but previously ran Windows 7 successfully). Only my laptop exhibits this behavior and I have no idea why. It is just as you say...as soon as I click the Item Pictures tab on the Item Properties dialog box, the application disappears from the screen with no error messages, no notification of any kind. And upon restart, all my data is as it was before the incident. Although it's good that it doesn't lose data, I cannot add or manage pictures from my laptop. That's a hassle. Clearly the app doesn't like something, but its not clear what that is or how to remedy it.
  2. One other thought. Although it may be too late to include this request in the upcoming release, I suggest it would be nice to allow attachments to be added to line items in the notebook. I typically scan my receipts for service and attach them to the main item, but they really belong with each maintenance event instead. After a large number of line items accumulate, sorting out which attachment goes with which line item becomes laborious and error-prone unless you name the attachments in a way to help associate them with the right line item. It would be simpler and easier to just allow associating an attachment with each line item in the notebook. my 2cents
  3. Thank you! Looking forward to seeing all the improvements.
  4. Though I've had the software for years, I just noticed that the details panel (on the lower right side of the main interface to HomeManage) does not display all of the line items in the Notebook. I track the details of auto maintenance in the Notebook, as that seems an appropriate use of the notebook. Although I have 34 line items in the Notebook, only the most recent 11 entries show up on the details panel. This is an issue because it is in the details panel that the Notebook entries are readable, not the Notebook entry dialog box. The Notebook entry dialog box, the box where I add line items, is cramped and doesn't allow me to see more than one entry at a time, so the details panel is better for an overview of service to my vehicle. And unlike the Comments box on the Additional tab of the Item Properties box, pressing the Enter key closes the dialog box instead of inserting a new line. By trial and error I learned that only CTRL+Enter inserts a new line. Is this the intended behavior? Another issue with the Notebook occurs in the dialog box where entries are added/edited. The description box is extremely limited in the amount of text it will accept, making it difficult or even impossible to capture enough details to describe a fairly typical maintenance event.
  5. I've had the same problem. It's quite frustrating to see it there but yet cannot move it anywhere, and cannot even delete it. And AFAIK there is no user guide to tell you how the program is designed to handle disposed assets so you can do what it expects.
  6. Thanks for such a quick response! I've sent an email to the address above with my code. Hope to hear back soon. David
  7. Just yesterday I upgraded the CPU in my computer and as part of the process of validating a successful upgrade, I ran most of the apps that I use frequently. When I ran HomeManage, I got an activation request screen, as you do when you're running the application in trial mode. So I chose to activate now, put in my license code and got the response that my license code is already in use! I am the only one who uses the software (for years) and I don't know why the activation process won't recognize me. I'm not aware of any other changes on my machine, so I'm tempted to conclude that the CPU upgrade triggered this. I don't understand this approach. It's the same machine, same user, same operating system -- Windows 10 x64 1809 (10.0.17763.503) -- that I've been using with HomeManage 2018 since I upgraded to this version. Anyone else have this issue? Any help would be appreciated! HomeManage version is 18.0.0.13 David
  8. Any information as to what features, changes or fixes we might anticipate in this "major new version"?
  9. I noticed the same thing about the file format -- it's MS Access, and I can access it with Access and if needed manipulate data. But I have hesitated to do that because I don't know what the code base does with the data. I could guess, but that would be dangerous. Did you write an app that uses the Access format or abandon that for something else?
  10. I see you still haven't gotten a response. That's too bad. Looks like the question is being ignored.
  11. The "Check For Updates" menu item doesn't work for me either. It launches a dialog box that looks right, it runs (green progress bar completes quickly), then says the update application has been updated and a restart is needed. After the restart of HomeManage, running the check again produces the same results. No update check is ever completed -- only updates to the update application. The exact message says: "The update application has been updated and must restart in order to continue." I attached a picture of this box.
  12. Are any of these features on your roadmap for any future version of the application?
  13. I've got a lot of my home items cataloged in the Home Inventory application and it does a great job of tracking most information. I think it could be even more useful if there were a counterpart app on iOS so that I could take my database with me in my iPhone. There are a couple reasons I think this would be good. 1) Getting detailed information like item numbers, serial numbers, UPC numbers or collection names is sometimes hard to get without going back to the vendor. And when it comes time to find replacement parts, that information can be critical on, say a furniture set that is several years old. Having pictures and other tracked info available on the iPhone would make it easy to show a dealer/vendor the product and perhaps get better identification information for it. 2) Having my inventory available on the go would also be helpful for avoiding duplication in buying products. It would also be helpful in the opposite case when you want to ensure that you're buying a matching duplicate (if for example you wanted to add to the set). 3) Having the database on iPhone (or in iCloud) would serve as a good backup for the data as well. 4) Showing your product to a friend who might be interested in acquiring it is not possible unless you're at home. But with the database on iPhone, this becomes a possibility. Are there any plans to build an iOS version of the application that works in conjunction (with the same dataset) with HomeManage 2018, 2019, 2020, etc.? David
  14. Steve, My copy does this too (greyed out Lookup button) and I don't know why it does. However, I've found that when I scan some barcodes, the lookup automatically fills in information in a few fields; otherwise it uses the word "null". David
  15. That's a great question. I haven't seen a changelog, but would be nice to. David
  16. I went to check HomeManage 2018 for updates by using the menuitem under the Help menu "Check for Updates...". When I clicked, nothing happened. The normal application that runs to check for updates did not appear on screen, and there was no error message or dialog box -- absolutely nothing happened. Ultimately I checked the home folder for the application and found what appears to be an outdated application called CheckForUpdate_HM2017.exe. I wondered how that happened, but figured it may be because I installed the 2018 version on top of the 2017 version. So I renamed the .exe to .exe_SAVE and the associated .dat file to .dat_SAVE and reinstalled the application. After reinstallation, I found CheckForUpdate_HM2017.exe and CheckForUpdate_HM2017.dat in the home folder. I launched CheckForUpdate_HM2017.exe and it as expected. I clicked through the NEXT buttons to check for an update, and it reported that "You already have the most recent version of HomeManage 2017 installed on your system." Is it checking for version 2017 or version 2018? David
  17. I opened the Preferences dialog box (Tools>Preferences) and went to the Field Names tab to check on some fields I had added some time ago. While there, I noticed something odd. There are duplicate entries for some (many) text fields. The duplicate names are in the "Property" column, not the "Value" column. For example, I found 2 rows each for these fields: User Field 10 (both of these have the exact same entries in the Value field - a value I entered) User Field 11 (one of the duplicate rows has an entry in the Value column that I entered; the other is blank) User Field 12 (one of the duplicate rows has an entry in the Value column that I entered; the other is blank) and User Fields 4, 5, 6, 7, 8, and 9 (one of the duplicate rows has an entry in the Value column that I entered; the other is blank) Even odder, there were no duplicate fields for any User Fields higher than User Field 12. I also noticed that all of the duplicate fields except 10 have one Value entry that I entered and the other is blank; see the attached picture for examples. The fields are also not sorted by number -- as you can see in the picture, User Field 2 comes after User Field 19. It looks like they're sorted like text. The sorting is not a critical matter, just an oddity. David
  18. Great idea. There are several ways to compartmentalize the images, including using the asset number as a folder. If that's done, then you could include attachments in the asset folder for each asset. For example, PDF of the warranty or user manual for a purchased device or appliance.
  19. Most times when I'm inventorying an item, only one or two photos is needed to show the item. However some products come with multiple parts/items and a picture of each critical item is useful to have in the list of pictures. And when the product is new, I will easily recall which picture goes with each item in the product. However after years have passed, I may not recall what's what. Allowing the pictures to have an optional caption would make identification of the items faster and more accurate. It would also make referencing a particular item in, say the notebook, clearer so that whatever note is added, the meaning of whatever activity was taken is clear. It's not a major thing, but would be nice to have. Also, on the primary UI screen, I would show the caption for quick identification that the caption has been entered correctly for each item. Thanks for your consideration! David
  20. Thank you for this work-around. I tested it and it works, but I don't know what else I broke with this change. I hope you will fix this issue in the next update to HomeManage. I still see it as an issue (and your suggestion as a work-around) for this reason. If there are other applications on my machine that are like HomeManage, this change may break them. If the application is built around a specific date format rather than using the system date format, this issue will always be there. Currently I know of no applications that this will break, but since the change is at the operating system level, it is system wide and can affect all applications, so I'll need to be on the lookout for problems in other applications. Thanks, David
  21. I noticed the format in your snippet above is yyyy-MM-dd. See my snippet for comparison (it is M/d/yyyy). I see no place to change this formatting. I attempted to enter the same dates in your example above, April 12, 2011 and November 21, 2017, but using the M/d/yyyy formatting expected in my application. See the pics below for the final result. What happens is the month placeholder will only accept 1 digit, even though the cursor can be moved 1 place in the field, demonstrating that there are 2 places in the field. So for April 12, 2011, I tried entering digits in this order with no spaces: 4122011. The day field only accepts the first digit, then the cursor jumps to the year field, where it places the 2 in 12 followed by the first 3 digits of 2011. I got an error beep on the last digit of 2011. Afterwards, I entered the Received Date typing the following digits with no spaces: 11212017. I got the error beep on the last two digits, 17. Below are the results:
  22. After closing and restarting the application, I noticed that all 4 images of the House location now appear in the images tab just as they should. I also noticed that the application allowed me to add the same 3 images to the Shed location that I attempted to add above, this time without improperly rotating any of the images.
  23. When I clicked the properties of the House location, a dialog with tabs General, Attachments, Item Picture(s) and Notebook appeared. My goal was to add some lawn maintenance that I had done recently to the Notebook. That task worked well, but I decided to add images of the house -- didn't realize that I could. Adding the images to House worked as expected. I then went to add images of the shed behind the house to a location I created called Shed. I added 3 images in the order they appear in the app, 1, 2, 3. The first two images worked as expected and the images appeared in the dialog as expected -- no surprises. However, the third image appeared rotated 90 degree CC, even though I took the image on an iPhone in portrait mode (all the images of the shed were taken in portrait mode). I then clicked the Edit button thinking the app may allow me to rotate the image, but nothing happened. So while viewing the 1 rotated image, I pressed the Clear button to clear it so I could try re-adding the image. Re-adding the image worked (I used drag and drop to add all images) but the image appeared with the same rotation problem. I cleared the image. When the image addition failed, by habit I clicked on image 2 and image 1 just to check them. They both appeared to be missing (blank all white panel) -- a surprise since I only intended to clear the one image. So the issues so far are: 1) the app rotated an image improperly 2) the app appears to have cleared all images for the location when I only intended to clear the one mis-rotated image 3) the Edit button did nothing I then went back to the House location properties to check the images there. They all appeared to be correct with no rotation problems, even though of the four images of the house I took, 2 were in portrait mode and 2 were in landscape mode. I selected one of the images, then clicked the Edit button just as a test to see if it would fail again. The Edit button opened MS Paint! Without editing anything, I closed Paint and went back to the Shed to attempt adding all the images again. There were still no images showing on the shed, so I used drag-n-drop to put the same images in the same placeholders. Although there were no errors triggered, and the drag-n-drop operation appeared to work as normal, no images showed up in the locations. The Edit button was grayed out. I went back to the House location to view the images there, and the last image (image 4) was missing, and the other three appeared all black -- completely black with no shades of any color. I clicked on Edit and the actual image appeared in Paint. Without editing the image I closed Paint and the House properties dialog box. As I'm trying to figure out what's happening here, I went back to the Shed and House locations a few times just to check what was visible. Ultimately, all the house images seem to have disappeared even though I never edited any of them, and I never clicked the Clear button (no need to -- all 4 images were perfect). Since I know where the application stores the images, I went to that location in Explorer. All 4 images of the house were present with names like Location184(1).jpg, Location184(2).jpg, etc. None of the pictures of the Shed location were present. Note that all the image manipulation buttons are active in the House properties dialog box, which makes sense since the images all exist; you just can't see them in the pplication image boxes. However, all of the same buttons are grayed out for the Shed location, which also makes sense since the images no longer exist. What doesn't make sense is not being able to re-add the images to the Shed location. 4) So even though the shed images were not present, the application would not let me add images of the shed 5) Even though the images of the house are still present, the application doesn't show them in the properties dialog box for the House location There appears to be plenty wrong with the way the application manages images. I can't figure it out. All images added in this exercise were in JPG format from an 8MP iPhone camera. - David
  24. Thanks. Looking forward to the fix. I've noticed several issues with how the application handles images. I'll be posting an additional one or two today that I just came across.
×
×
  • Create New...