Jump to content

Stamp Manage 2018 Slow to Low - Fixed

Guest Roger

Recommended Posts

Guest Roger

For quite a few months Stampmanage 2018 was very slow to load on my computer, taking anywhere from 15 seconds to a half hour to load. My computer has an Intel Core i7, solid state drive, 16GB memory, etc.  It has always been fast to load.  Today I finally figured out what was causing the slowdown. I have the latest version of Acronis True Image backup software running on my computer and sometime this past year they added a feature called "Active Protection".  At least I noticed the option the past year.  Today when StampManage was slow to load I went to Ctl-Alt-Del Task Manager to see what StampManage was doing.  That was when I noticed that there was a task running called Acronis Active Protection Service, that was using a lot of memory. So I ran Acronis and saw that Active Protection had flagged StampManage as being a suspicious process.  Once I took it off that list and said it was Trusted, StampManage started loading in about one second.  I have been smiling ever since.

Link to comment
Share on other sites

I was the one that posted this discovery.  I forgot to log in as myself.  Anyhow,  I can report that StampManage continues to load real fast!  The problem was so bad that I had started looking around for other software to use with my stamps.  I didn't find anything that came close to StampManage.  It's not perfect but it is a very good program.

Link to comment
Share on other sites

  • 1 year later...

Stampmanage 2020 is taking about 11 minutes to load!!!  I also have Acronis and see that "Active Protection" is running.  It is not flagging StampManage as a suspicious process.  In Acronis > Active Protection > Manage Processes > Monitored Processes, it says "This process does not have a trusted certificate".  I manually added StampManage as "Allowed to Start".   However that made no difference in time for the software to load.  I did not have this problem with StampManage 2019.

Is there a way for StampManage to use a trusted certificate, in case some other software is also taking issue with this?  Any other ideas as to how to improve this unacceptable start-up time?



Link to comment
Share on other sites

Here is what worked for me to solve this long start-up time, if you are using Windows 10:

  1. Open the “Start” menu. 
  2. Click on “Settings.”
  3. In the “Find a Setting” search box, type in “Firewall.”
  4. On the left, click on “Allow an app or feature through Windows Firewall.”
  5. Now, the “Allowed App” windows will pop up. Click on the “Change Settings” button.
  6. Click "Allow another app".
  7. Browse to find the StampManage executable file. 
  8. Check the boxes under the type of networks that will allow this communication (private or public).
  9. Click on “OK” to save your new settings.

This dropped my startup time time from 11 minutes to 40 seconds, not great, but dramatically better.

Link to comment
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...