Jump to content

MySQL problem on Dreamhost: GetRows failed

Recommended Posts

I'm trying to get the trial Enterprise version running using MySQL on Dreamhost.com shared server.

I've succeeded only partly, and need help filling in the details. Can you please: tell me:

  • Your database file specifies the ANSI character set, but Dreamhost's MySQL installation used Unicode. Should I use the ANSI or UNICODE MySQL ODBC connector?
  • What import settings should be used?
    1. ​Character set: (default is utf8, but I chose latin1)
    2. Partial import (default is checked)
    3. SQL compatibility mode (default is NONE; I presume this means compatibility with MySQL 5.x. Is your SQL file built for another version instead? The other relevant choices are MYSQL323 and MYSQL40.)

    [*]​Using the above settings, I get these errors once in AssetManage:

    1. ​On launching, after selecting the ODBC driver:​​

      1. DBC--call failed. (3146)​
      2. GetRows failed. The requested column is not a member of this recordset. (4098)
  • ​After that, I can interact with the database a little bit, but doing the following in the application results in these errors:
    1. ​​Clicking on Main Office results in the same 4098 error above.
    2. Add Item launches the dialog box without error, but pressing OK results in the 4098 error followed by "encountered an improper argument". Clicking OK again results in "Update or CancelUpdate without AdNew or Edit. (3020)".

That's as far as I've gotten. In setting up the application, I followed the procedures I wrote below.

Dreamhost database configuration

Shared MySQL servers on Dreamhost have a few limitations that impact setup and usage:

v Database creation must be done in Dreamhost Control Panel

o From the menu, select “Goodies”, then “MySQL Databases”

o Scroll down to the bottom of the page to “Create a new MySQL database”, choosing whatever hostname and user is appropriate for your use, then click the “Add new database now!” button.

o Modify the AssetMng.sql file to eliminate the CREATE DATABASE command (which will fail. Delete these lines::

CREATE DATABASE `assetmng2007`


COLLATE `latin1_swedish_ci`;

o Database names must be unique on the shared server. If Dreamhost reports that database name is already in use, you will have to change the database name from the default. If you do, change the following line in AssetMng.sql to match:

USE `assetmng2007`;

AssetManage Enterprise Configuration

An ODBC connector (driver) for MySQL must be installed prior to configuring AssetManage for a database.

1. Download the 32-bit connector http://dev.mysql.com/downloads/connector/odbc/ (you will need an Oracle.com account)

2. Install the connector. It will not be visible as a separate application.

3. Install AssetManage Enterprise application

4. Launch AssetManage by right-clicking the application icon and then left-clicking Run as Administrator

5. In the Select Data Source dialog box that appears next, switch to the Machine Data Source tab, click the New button, select the System Data Source radio button and click the Next button.

6. In the Select a driver… list, scroll to the bottom and select “MySQL ODBC 5.3 ANSI Driver? The click the Next button, then the Finish button.

7. In the MySQL Connector/ODBC Data Source Configuration dialog box, enter the following:

a. Data Source Name: “ARCBA_DST_ASSETS”

b. Description: “ARCBA DST Asset Tracking”

c. TCP/IP Server: “mysql.arcba.net” Port: “3306”

d. User: “arcba”

e. Password: “DST-WB6RC-R@d!0”

f. Database: “assetmng2007”

g. Click the OK button

8. Back in the Select Data Source dialog box, make sure the entry you just made is highlighted, then click the OK button

Link to comment
Share on other sites

Hi, the SQL file is a generic SQL file that was exported from an SQL Server database.

You should run the SQL file as a query to generate the database in MySQL

Regarding the settings:

1/ Should be UTF-8

2/ Partial import? The entire SQL file should be run.

3/ MYSQL40 should be ok

The errors you are getting happen when there is a mismatch between the schema the client is expecting and that of the database that was created.

Did you download the program around May 31 or earlier? As we put up a major new build around that time.

Link to comment
Share on other sites

  • 4 weeks later...

I've downloaded the new version, and tried importing its SQL file, but found the following problems:

1) When importing it, the web interface timed out after the upload was complete.

2) When I followed the instructions from DreamHost tech support to import via the command line, I got different errors, as detailed in my message to them below.

The first was ERROR 1193 (HY000) at line 4: Unknown system variable 'QUOTED_IDENTIFIER'

I commented that one out, and then got

The second was ERROR 1064 (42000) at line 6: You have an error in your SQL syntax;

Their tech support speculates that the file may not be valid for mySQL. Can you please advise what else I should try?


Thanks for your reply. I checked with my mysql admin and based on the

error you provided it appears there may be an issue with the sql file you

are trying to import. Seems it may not actually be a mysql back up. I

recommend contacting your software vendor to confirm if this is a mysql

back up or if it can be converted to a mysql back up. This may be just a

matter of re-formatting your file with your software vendor.

If you have any other questions or concerns, don't hesitate to email us



Hector N.

On Tue, 30 Jun 2015, you wrote:

I could use some more help, indeed.

I've logged into the shell and tried the import using this command from:


mysql -h mysql.arcba.net -u arcba -p assetmng2010 <


But I get this response:

ERROR 1193 (HY000) at line 4: Unknown system variable 'QUOTED_IDENTIFIER'

When I comment out that line, I get this error:

ERROR 1064 (42000) at line 6: You have an error in your SQL syntax;

check the manual that corresponds to your MySQL server version for the

right syntax to use near '[dbo].[Assets](

[AssetID] [int] IDENTITY(1,1) NOT NULL,

[invoiceNum] [int] NUL' at line 1

Link to comment
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...